The topology is as follows:
The requirements are as follows:
The internal network needs to access the external network, use dual egress devices, dual-line out, and the two lines need to back up each other, and load balancing is required.
MSR36-20_7 is the internal loopback address 1.1.1.1 of the operator router, which is used to test network connectivity
MSR36-20_1 connects telecommunications lines for the company’s exit routers
MSR36-20_2 is the company’s exit router connection line
S5820V-54QS is the company’s core switch
The device configuration is as follows:
Core Switch S5820V2-54QS:
track 1 nqa entry admin test1 reaction 1
#
vlan 10
vlan 20
vlan 30
policy-based-route other permit node 5
if-match acl 3101
apply next-hop 10.249.254.15
nqa entry admin test1
type icmp-echo
destination ip 1.1.1.1
frequency 10
history-record enable
next-hop ip 10.249.254.16
probe count 10
probe timeout 500
reaction 1 checked-element probe-fail threshold-type consecutive 5 action-type trigger-only
source ip 10.249.254.10
nqa schedule admin test1 start-time now lifetime forever
interface Vlan-interface1
interface Vlan-interface10
ip address 10.249.254.10 255.255.255.0
ip policy-based-route other
interface Vlan-interface20
ip address 192.168.1.1 255.255.255.0
interface Vlan-interface30
ip address 192.168.2.1 255.255.255.0
interface GigabitEthernet1/0/1
port link-mode bridge
port access vlan 10
interface GigabitEthernet1/0/2
port access vlan 30
interface GigabitEthernet1/0/3
interface GigabitEthernet1/0/4
port access vlan 20
ip route-static 0.0.0.0 0 10.249.254.15 preference 200
ip route-static 0.0.0.0 0 10.249.254.16 track 1
acl advanced 3101
rule 0 permit ip source 192.168.2.0 0.0.0.255
Telecom Router MSR36-20_1:
interface GigabitEthernet0/0
port link-mode route
combo enable copper
ip address 10.249.254.15 255.255.255.0
interface GigabitEthernet0/1
ip address 172.16.254.241 255.255.255.252
ip route-static 0.0.0.0 0 172.16.254.242
ip route-static 1.1.1.0 24 GigabitEthernet0/1 172.16.254.242
ip route-static 192.168.1.0 24 GigabitEthernet0/0 10.249.254.10
ip route-static 192.168.2.0 24 GigabitEthernet0/0 10.249.254.10
Unicom router MSR3620_2:
sysname liantong
ip address 10.249.254.16 255.255.255.0
ip address 172.16.254.237 255.255.255.252
ip route-static 1.1.1.0 24 GigabitEthernet0/1 172.16.254.238
Operator MSR36-20_7:
interface LoopBack0
ip address 1.1.1.1 255.255.255.0
ip address 172.16.254.242 255.255.255.252
ip address 172.16.254.238 255.255.255.252
ip route-static 10.249.254.0 24 GigabitEthernet0/0 172.16.254.241
ip route-static 10.249.254.0 24 GigabitEthernet0/1 172.16.254.237
ip route-static 192.168.1.0 24 GigabitEthernet0/0 172.16.254.241
ip route-static 192.168.1.0 24 GigabitEthernet0/1 172.16.254.237
ip route-static 192.168.2.0 24 GigabitEthernet0/0 172.16.254.241
ip route-static 192.168.2.0 24 GigabitEthernet0/1 172.16.254.237
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
#
port link-mode bridge
port link-mode bridge
port link-mode bridge
port access vlan 10
interface GigabitEthernet0/0
interface GigabitEthernet0/0
port link-mode route
port link-mode route
port link-mode route
port link-mode route
port link-mode route
combo enable copper
combo enable copper
combo enable copper
interface GigabitEthernet0/1
interface GigabitEthernet0/1
ip route-static 192.168.1.0 24 GigabitEthernet0/0 10.249.254.10
ip route-static 192.168.2.0 24 GigabitEthernet0/0 10.249.254.10